Required Messenger Upgrade

As part of Microsoft's Trustworthy Computing initiative, Microsoft is delivering a security update for some users that connect to the .NET Messenger Service for instant messaging using MSN Messenger or Windows Messenger.

Please click on the Messenger client name or device type below to determine whether you need to upgrade your client or not.

MSN Messenger for Windows Mobile-based Pocket PCs and Smartphones
MSN Messenger for MSN Companion
MSN Messenger for Windows
MSN Messenger for Mac
Windows Messenger
Windows Messenger for Windows CE .NET-based Devices


MSN Messenger for Windows Mobile-based Pocket PCs and Smartphones

As part of the MSN Messenger Security Update, Microsoft is developing updates for Windows Mobile-based Pocket PCs and Smartphones. Please check back at this web site for updates and more information.

back to top


MSN Messenger for MSN Companion

We're sorry but we discontinued Messenger support for MSN Companion in October 2003.

back to top


MSN Messenger for Windows

Windows 95

If you are using Windows 95 operating system, you need to run MSN Messenger version 5.0 for Windows 95.  To check your version of MSN Messenger click Help, and then click About in the main window.

If you are running a version older than 5.0, click here to upgrade.

Windows NT 4.0

If you are using Windows NT 4.0 operating system, you need to run MSN Messenger version 5.0 for Windows NT 4.0.  To check your version of MSN Messenger click Help, and then click About in the main window.

If you are running a version older than 5.0, click here to upgrade.

Windows 98/ME/2000/XP

If you are using Windows 98, Windows ME, Windows 2000 or Windows XP operating systems, you need to run MSN Messenger version 5.0 or later.  To check your version of MSN Messenger click Help, and then click About in the main window.

If you are running a version older than 5.0, click here to upgrade.

back to top


MSN Messenger for Mac

Mac OS 8

We're sorry but we have discontinued support for MSN Messenger for Mac on OS 8.x. We only support MSN Messenger for Mac on OS 9.2.2 and OS X 10.1.3 or later.

Mac OS 9.2.2 or later

If you are using Mac OS 9.2.2 or later, you need to run MSN Messenger for Mac 2.5 or later.  You can check your version of Messenger by selecting About MSN Messenger from the Apple menu.

If you are running a version older than MSN Messenger for Mac 2.5, click here to upgrade.

Mac OS X 10.1.3 or later

If you are using Mac OS X 10.1.3 or later, you need to run MSN Messenger for Mac 3.5.0 or later, which requires OS 10.1.3 or later version of the operating system.  You can check your version of Messenger by selecting About MSN Messenger from the MSN Messenger menu.

If you are running a version older than 3.5.0, click here to upgrade.

back to top


Windows Messenger

If you are using Windows XP, you need to run Windows Messenger version 4.7.2000 or later.

To check your version of Windows Messenger click Help, and then click About in the main window.

If you are running a version older than 4.7.2000, click here to upgrade.

back to top


Windows Messenger for Windows CE .NET-based Devices

We're sorry, but there is no upgrade available for the Windows CE .NET-based devices at this time.

back to top